The original words of Phanes, tirelessly carved into a slab of "No'".

system-config-kickstart bug fix on Fedora 23

[highlighter line=0]

Found a bug in a fresh install of Fedora 23.

[phanes@localhost ~]$ sudo dnf install imgbased-kickstarts python-dnf-plugins-extras-kickstart pykickstart custom-kickstarts python3-kickstart system-config-kickstart spin-kickstarts fedora-kickstarts

You’ll get something like this:

[phanes@localhost ~]$ sudo system-config-kickstart Traceback (most recent call last):
File "/bin/system-config-kickstart", line 88, in 
import kickstartGui
File "/usr/share/system-config-kickstart/kickstartGui.py", line 29, in 
import basic
File "/usr/share/system-config-kickstart/basic.py", line 39, in 
from pykickstart.constants import *
ImportError: No module named pykickstart.constants

The repair is:

[phanes@localhost ~]$ sudo ln -s /usr/lib/python3.4/site-packages/pykickstart /usr/share/system-config-kickstart/

I bet you thought it was done.  Nope, because they also failed to manage their python dependencies:

[phanes@localhost ~]$ sudo system-config-kickstart
Traceback (most recent call last):
File "/bin/system-config-kickstart", line 88, in 
import kickstartGui
File "/usr/share/system-config-kickstart/kickstartGui.py", line 39, in 
import packages
File "/usr/share/system-config-kickstart/packages.py", line 37, in 
from pykickstart.parser import Group
File "/usr/share/system-config-kickstart/pykickstart/parser.py", line 42, in 
from pykickstart import constants, version
File "/usr/share/system-config-kickstart/pykickstart/version.py", line 56, in 
from pykickstart.load import load_to_str
File "/usr/share/system-config-kickstart/pykickstart/load.py", line 20, in 
import requests
ImportError: No module named requests

So you’ll need to install the requests module.  I use pip since I’m starting not to trust the Distro packages for this kind of thing:

phanes@localhost ~]$ sudo pip install requests
You are using pip version 7.1.0, however version 8.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Collecting requests
Downloading requests-2.9.1-py2.py3-none-any.whl (501kB)
100% |████████████████████████████████| 503kB 928kB/s
Installing collected packages: requests
Successfully installed requests-2.9.1

Then a

sudo system-config-kickstart

should work just fine.  Does for me 🙂

Really need to look at a new distro, I’m getting really tired of having stuff be broken out of the box that isn’t in other distros.  I remember fighting this battle with ruby dependencies a few weeks ago for installing this domain’s gitlab instance that I use for showcasing code or tracking work on more nasty fixes as they come up.

Next Post

Previous Post

3 Comments

  1. Neil 2016-03-07

    Thanks for this.

    It’s been annoying me for a couple of days now 🙂

  2. Paddy 2016-08-22

    Thanks! Working for me on Fedora 23

  3. Rick 2016-09-22

    Hmm, the problem is in fc24 too.

Leave a Reply to Rick Cancel reply

© 2021 Phanes' Canon

The Personal Blog of Chris Punches